Problème
WebRTC ne se charge pas lors du visionnage de flux vidéo en direct. Vous pouvez vérifier cela en survolant le bouton rouge en direct lors de la lecture des flux en direct. Une croix s’affiche à côté de faible latence si WebRTC n’a pas pu se charger :
Cause
Cela peut être causé par ce qui suit :
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Les ports du pare-feu sont bloqués
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Le périphérique NAT du réseau ne prend pas en charge le mappage indépendant du terminal ou ne l’a pas activé.
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L’intervalle d’image clé de la caméra est trop élevé.
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Le débit binaire de la caméra est trop élevé.
Solution
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Vérifiez que l’accès requis a été autorisé sur le pare-feu (include link to firewall doc) :
Tableau 1. Serveurs Web RTC/Twilio Stun
US1
Côte Est des États-Unis (Virginie)
34.203.254.0 - 34.203.254.255, 54.172.60.0 - 54.172.61.255, 34.203.250.0 - 34.203.251.255, 3.235.111.128 - 3.235.111.255
US2
Côte Ouest des États-Unis (Oregon)
34.216.110.128 - 34.216.110.159, 54.244.51.0 - 54.244.51.255, 44.234.69.0 - 44.234.69.127
Ports : 443, 3 478 (TCP/UDP), 5 349 (TCP/UDP), 10 000-60 000 (UDP)
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Vérifiez que le périphérique NAT de votre réseau prend en charge le mappage indépendant du terminal.
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Vérifiez l’intervalle d’image clé sur la caméra. Cela devrait être ~ 1 seconde.
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Réduisez le débit binaire de la caméra à 1 Mb/s ou aussi près que possible sans affecter la qualité de l’image.